Elgato Stream Deck and Easyworship remote

I installed the Easy Worship plugin on the computer with the stream deck attached, and had everything configured a couple weeks ago. Last week I setup a new machine to host Easyworship, and when I tried to pair the stream deck it says a license is required. I haven't had any issues pairing android or ios devices. What is the deal?

1 person has this question

image


Here's a screenshot of what I'm seeing when I try to pair the stream deck on our new PC.  It was able to pair it with the old PC.

Ok, yes. You do need to have an active EW subscription to be able to use the Stream Deck plugin.

This was working fine on our old pc, and I registered the new PC.

was the old pc registered or was it running the demo with the watermark?

The old one was registered. I deactivated the old PC and registered the new one.
I am able to pair mobile devices just not the stream deck.

The remote app works with a one time purchase license or subscription. The Stream Deck plugin and MIDI require a subscription to work.

did you also press teh remote icon. (lock or a remote controle) to activate the remote?

Ok. That explains the message. Is this a new requirement or was it an unexpected feature that allowed it to work on our previous machine without a subscription? I'm just a little frustrated because it was working with no indication of any additional requirements. I had already requested funds to purchase the needed hardware to setup a remote to be used on stage, and now I have to go back and request an additional $200 a year just to use a stream deck.

Are you sure you were using the actual plugin on the old computer? We just released the official Stream Deck plugin the end of November and it has always required a subscription to work. Before that, you possibly could have been using hotkeys. I'm not sure how the plugin from Stream Deck was working on the old computer without a subscription.

Yes. I only found it in the elgato plugin store a few weeks ago. I just happened to be browsing through to see if there were any new plugins. I installed it and it just worked. It paired with our easyworship pc without any issues.

I have not seen or heard of that yet. Can you give a screen shot of the error? When exactly does that message come up? When you press the key on the Stream Deck, or when you press Pair in EW?

It's happening when I pair from the stream deck. The message appears in the easy worship remote dropdown where you would select the device. I'll get a screenshot this evening.
Login to post a comment