Easyworship 7 freezes when in use. Especially when you are fast on the laptop.

1 person has this question

Ruth, Sorry you are having this issue. Can I ask what build number you are running on EW? Help>About EasyWorship.

If possible, we would like to remote into your computer and run a debugger to get a report for our developers to take a look at.

You can schedule a callback from a tech by going to www.easyworship.com/book

Hi, I had the same issue for the first time yesterday during our church service.  The program froze at the beginning of the service.  I was able to force it to close using task manager and then opened it again.  It worked for awhile just fine but then it froze again later in the service.  I am using the most up to date version (  Could I please get some assistance to see if there is a fix?  Thank you!

I am having the same problem with version (

Load Easy Worship, it will work for a few minutes then freeze; I. have to close it with task manager.

The start again and it seems to work normally without freezing.

Never had this problem with previous versions.


Ruth, Jonathan, and Kevin, can you please download and install from our downloads page and then after opening, go to Profiles menu > Utilities > Clear Thumbnail Cache and see if it still freezes after that?

If it does, please go to www.easyworship.com/book and schedule a callback from a tech and they will run a debugger on your computer that will help us determine what is causing the freezing.

This seems to be working for me so far.  Is clearing the thumbnail cache something I should do on a periodic basis?  Thanks!

I was having the same freezing problem on Sunday and did not livestream or record our service as I thought maybe there was a conflict with OBS studios, but the freezing still happened with everything closed out but easyworship. Software is fully up to date. Is there any other resolutions since Sunday morning? I will try clearning the cache as described above...

Followed Dan's instruction above and have no problems since.

Thank you.

I have been having the same issue. I even changed my laptop and still the same issue. And I have the latest version of EW7
Login to post a comment