[v6 General Discussion] Saving

EW6 is open; added a Presentation, press Save to save the day's schedule and this message appears (truncated a bit): "Unable to save...verify none of the media files needed are being used." The fix, please?

Our pleasure, stutes! So glad we were able to figure this out together.
An update to my "Unable to save schedule! Please verify that none of the media files needed are being used by another process" error.

So I had numerous theories as to why EW started kicking out this error back in early May every time I attempted to insert our announcements PowerPoint into our EW6 schedule:
1. Sanctuary computer is on Windows to run EW, but I make the PowerPoint on my mac in the office
2. Dropbox syncing between the two computers was locking the file perhaps; perhaps Dropbox was the "other process"
3. Fonts weren't the same on the two computers
4. There was a slide (or more) EW was having issues with in my PowerPoint; font issues? Edits to my master slides causing the problem? (I recently attempted to edit and remove the master slides I no longer needed)

In my attempt to work around the problem, I went through the trouble of exporting all the slides as images, and then re-inserting them back into PowerPoint, and using this "flattened"/image-only PowerPoint as my announcements PowerPoint in our schedule, because for some reason when the PowerPoint was "flattened" then it worked fine with EW. Since this hack was working, I was suspecting the actual issue was font related. But that wasn't the problem after all.

Well GHarris above was kind enough to follow up with me in a direct email, and open a ticket regarding the issue; Jerod helped with the ticket and had me install a debugger to track the errors EW was having. The only bug it was finding was about a JPG file; the bug simply referenced "....\Resources\SharedMedia\5x6r8.JPG".

It was that folder that was a big hint for me; I noticed EW seemed to making thumbnails of all the slides in my PowerPoints and putting it in this "SharedMedia" folder; so I started to suspect EW was having an issue creating a thumbnail for one (or more) of my slides in my PowerPoint. Sure enough, that was the case.

Oddly the slide that was the problem didn't even have any fonts on it. It was a slide that nothing but a JPG inserted in it; one we've used FOR YEARS to ask members to silence their mobile phones. The fix? I simply deleted the JPG from the slide, and re-inserted THE EXACT SAME JPG back into the PowerPoint file. Now EW works fine when we place the PowerPoint into the schedule.

As for the error "Unable to save schedule! Please verify that none of the media files needed are being used by another process"; I can only assume EW itself was the "process"... it was still working on a background process in an attempt to create a thumbnail of the slide with the problem JPG.

BTW, it is easy to determine the slide that is the problem; go live with the PowerPoint and scroll down; the slide will appear black because EW is not able to make a thumbnail of the file.

A big thanks to GHarris and Jerod for their help on tracking the bug down.
Allow me to add to what Gabe also said. We apologize for the confusion and for the issues you are still having with your EasyWorship program. Would you be so kind of email your file and a sample schedule to us? Despite of how the conversation went over the phone we would like you to know that we will be happy to help the best we can.

Please email us at support@easyworship.com, either myself Aaron, or one of our Tech Support representatives will help you with this issue. If we need to create a ticket we be delighted to do so as well.
Just sent you an email message (via this forum) about this, stutes. Please get back to me when you can. In the meantime, I'll bring this up to our Support team myself to see if they can re-create this issue. And did you already update to 6.2.1?
Having the exact same issue when I install a PowerPoint. I did as you suggested, GHarris, and called the support line. Waited for my turn for 20 minutes or so. When it was my turn the tech support wasn't interested in establishing a pattern or attempting to re-create the issue, nor passing it along to the developers as a bug. The phone tech was certain it is because of a corrupt file. I offered to send him the file, and he wasn't interested, as he stated he would have no way of being able to recreate my issue.

Putting the phone tech's "support" aside, my guess is that there is a particular slide in my PowerPoint that EW isn't liking for some reason; because I have another PowerPoint that is only two slides long (mainly a stripped down version of the bigger PowerPoint that isn't working), and this smaller PowerPoint works just fine in EW. The only thing I can figure is that this started happening when I attempted two things: 1) I removed a number of masters in my PowerPoint template and 2) I've tried to start using more fonts that I know exist on both computers that I work on (I created the PowerPoints in my office, not in the sanctuary).

But it may not be these things, because I've even opened the file in question on the computer in the sanctuary, edited it in the sanctuary, did a save as (therefore fonts are now referencing local font files) and EW still doesn't work with this second generation of the file.

The file size is SIGNIFICANTLY bigger than the PowerPoint that EW is willing to work with, and I notice a big lag in EW when "processing" the larger PowerPoint file; I am suspicious that the problem may just boil down to file size.

I do know this: my PowerPoints, regardless of size, were never a problem until last Friday, May 8.
Soundguy, sorry about this. We just saw two other forum posts today about this same issue. As far as I can tell, this issue is new. Would you please call our Support line and ask about this? It's important to establish a pattern and be able to re-create the issue on our end, so we can ask our developers to fix this bug. Thanks so much.