Azure VM with Easyworship 7.2/7.3 is freezing at startup


I'm building just a scheduler builder VM in MSFT Azure to make the schedule so that I don't have to leave a PC permanent on in our church to make this happen and we have free Microsoft non-profit credits for this.

I made a PC with 120Gb SSD drive, 8GB RAM dual core E5 CPU and a standard videocard.

(we use almost similar specs on a local HyperV server that we are closing down). 

However when I do a fresh install of 7.2 or 7.3 the whole console is just frozen; nothing works. Initially I was able to validate our license 1x but after that I can't click anywhere or even close/shutdown EW7; I have to kill it manually from the taskmanager.

CPU usage is low; there is 6GB RAM left and close to 10-15% videocard activity. 

Of course there is an application hang message after killing the EW7 process (ID: 1002). See below.

WOuld anyone have a suggestion how to get this resolved or did anyone else had any similar issue when making a 'scheduling VM" in Azure?

Thnx, Jeroen

Logboeknaam: Application

Bron: Application Hang

Datum: 13-11-2021 09:41:25


Taakcategorie: (101)

Niveau: Fout

Trefwoorden: Klassiek

Gebruiker: n.v.t.

Computer: virtueleBeamerP


Het programma EasyWorship.exe, versie reageert niet meer op Windows en is afgesloten. Als u wilt zien of er meer informatie over het probleem beschikbaar is, raadpleegt u de probleemgeschiedenis in het onderdeel Beveiliging en onderhoud van het Configuratiescherm.

 Proces-id: 6e8

 Starttijd: 01d7d867b4bc0735

 Eindtijd: 97

 Toepassingspad: C:\Program Files (x86)\Softouch\EasyWorship 7\EasyWorship.exe

 Rapport-id: 92218c3b-dc4a-4b63-89b5-0f3c4d688fd1

 Volledige pakketnaam met fout:

 Relatieve toepassings-id van pakket met fout:

 Type vastlopen: Cross-thread


<Event xmlns="">


    <Provider Name="Application Hang" />

    <EventID Qualifiers="0">1002</EventID>






    <TimeCreated SystemTime="2021-11-13T08:41:25.9527907Z" />


    <Correlation />

    <Execution ProcessID="0" ThreadID="0" />



    <Security />








    <Data>C:\Program Files (x86)\Softouch\EasyWorship 7\EasyWorship.exe</Data>











EW is not supported on VMs of any sort. See below for system requirements

Hi Donal, that is a known fact but in this case the UI just freezes entirely just at start of the application ; is there not any help required? We are not running the full presentation on the VM we just make the schedule; we do this as well on our HyperV 2018R2 server as a VM on windows 8 without any issues. I'm just not understanding why it freezes entirely on this VM; is there not any best effort support available ? An application should at least load normally right? I have all the specs except the very specific VIDEO card; but as long as I don't start a live presentation that should not matter such a lot that it doesn't even load the application right at all right?

I hope any best effort support can be provided? 

Not supported means that the company does not provide any technical support for doing it. As I'm not an employee I have no inside information. EW is designed to work a certain way and if an individual decides to install and attempt to use it outside of that they do so on their own. Look at it this way. If you try to pull a 20,000 pound trailer with a 4 cylinder Ford Pinto you are on your own. You might be able to do it, but the company that made the car and the trailer aren't going to do anything to support you doing it as they know it won't work properly, if at all.

We do not do any testing or developing on or for VMs and have no knowledge of how or if it will even work other than customers trying it. Unfortunately, we won't be able to help. Hopefully, another user has some experience with this and can help you.

hi Dan, Thanks for the messaging! Is there not any kind of best effort support available to at least look at the issue together? That an application just completely frezes up at initial start doesn't sound right either. There are even issues reported for this in physical environments with the same 1002 'application hang' event ID's. What would be the common steps that the EW SW engineering team would use to troubleshoot those? Would somebody know? LIke said: we are NOT running any publishing or broadcasting activity; we just like to build a schedule and save a schedule that is all; that should not need rocket science to run an application in a VM like we do locally on physical 2008R2 hyper-V server. There must be a check or maybe setting that I hope we can validate why it instantly hangs after the licensing is completed.

Send an email and they will send you a debugger that you can run and get a bug report for our developers to look at. 

Just to give you a little more information on this one, I received some insight from one of our developers. 

He mentioned that since Azure VMs have virtually no GPU capabilities, it's doubtful EW will work on it. There is not a 'schedule only' state of EasyWorship that doesn't use any graphics processing. EW is always using the GPU for thumbnails, DirectX and the sort. You can try deploying a VM on Azure that's specced to run GPU loads, but that's also doubtful that it will run properly.

Hi All, just a quick update that I got it to work in Azure. 
Its not that difficult at all but you need to have a GPU attached like Dan indicated and my suspicion was as well. It even got confirmed easily by looking at resource monitor on the VM in Azure where the GPU was like 30% on average busy and the CPU <10%; when playing embedded video's in our schedule the GPU spiked up to 60-70% while the CPU still didn't do a lot so its as expected and told that even the scheduler is heavily depending on a GPU.
As our local HyperVisor server had a G200 as onboard GPU (graphics card) this is why it still worked there.

Our VM details that worked in Azure are as follows: VM type: NV4as v4, 4 vCPU's (logical), 14Gb RAM, disk: 120Gb Standard - SSD LRS, W10pro 

Some additional settings for folks that like to run Easyworship 7.x in a virtual machine on a local hypervisor (windows server).
If you have the Virtual Machine build up with windows 8 then remote desktop protocol work out of the box as expected and EW7.x starts up as expected. 
If you start a same VM but with W10 then you will see that the application might start but hangs after that. After a minute or so you might see the error that the application is not performing. This is caused by the fact that W10 threats remote desktop sessions differently.

You need to enable these settings through gpedit.msc on your W10 client running as a VM:
Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Remote Session Environment: 

Use hardware graphics adapters for all Remote Desktop Services sessions enabled

Configure compression for RemoteFX data enabled

Enable RemoteFX encoding for RemoteFX clients designed for Windows Server 2008 R2 SP1 enabled

Use WDDM graphics display driver for Remote Desktop Connections disabled

RemoteFX for Windows Server 2008 R2 (folder)

  Configure RemoteFX enabled

  Optimize visual experience when using RemoteFX enabled

  Optimize visual experience for Remote Desktop Service Sessions enabled

 Especially the 'Use WDDM..." one did for me the trick; this is a new feature in W10 version 1903 or later and was by default set to 'not configures' I did disable it.

Just a final edit that now that I did this trick as above on the local HyperV server the same trick works very well in Azure Public Cloud. It is again especially the 'Use WDDM..' setting to be set to disabled what makes it work with EW7.x. So if you have a non-profit account with Microsoft ( then use your 3500 free Azure Grants to make a VM in Azure Public Cloud and create your schedules in the cloud and let them sync using MSFT OneDrive to your local EW PC. In my case we used the VMtype DS3v2 (E5-2673v4/14Gb Ram/SSD) (normally costing you like 170USD p/month :). If you have Questions just post them here and I'm happy to help.

Login to post a comment