[iOS Remote] iOS App - Not 100% reliable

Hi Easyworship

I'm loving the new remote control facility, and have tried it out on both iPhone and iPad.

I've noticed on a few occasions that the app has failed to 'connect' to the schedule.
It shows the live screen but I cannot do anything more. No schedule is shown, so no changes can be made.

If I close EW on the PC and restart, then reopen the schedule normally it's fine.

I think the common link is that when it fails to properly connect/link the schedule is currently live on a powerpoint.

If it's on a song then it's 100% reliable.

Anyone else seen similar issues?

This happens to me every time i load a schedule which triggers the "Update local computer/import schedule items" dialog.
Even after i import all items, the connection seems to be missing.

But if I then reload the schedule, IOS Remote connects again, and everything works.
Just had this issue. Tried to connect mid service. It showed the one slide that was live, but no schedule loaded.

My first instinct is to pull down to refresh/reload, but that is not there. No idea what is causing this, but a refresh button or slide down would be nice, assuming it could fix something like this.
Here is a screenshot showing the empty schedule...