[Android Remote] Android Version 9

I have been intermittently trialling the Android App and it worked flawlessly on the occasions I tried it - what a fantastic add-on. Well done guys!!!

However when I continued my tests recently I started seeing various glitches - in particular the app crashed at least twice. I'm afraid I didn't capture any information as we were in the middle of a service. My perception is that this might be due to a recent upgrade to Android 9 and I wondered if anyone else was having issues? Or whether I should be looking for other solutions.

My phone is a Motorala G6 Plus. App version 1.1.4 (build 32). We are running the latest EW7 on the church laptop.

I have noticed that an upgrade to a new version of Android like 8 to 9 will often times cause some problems. I know my Nokia 6.1 became started glitching and I noticed some lag at swiping. On the advice of the Nokia support forum I backed up the phone, did a reset, then restored the info and everything was fine after that. I've seen that same advice on other forums for other phones as well. Might be something to try.
Sounds like I should be looking for another solution. Could be a wifi issue? I haven't had that much experience so I'll use it some more and see what happens.
I've been using the app on my Pixel 2 XL with Android 9 and can't say I've had these issues.
We have not gotten any feed back about this yet. I have reported it to the developers.