[Android Remote] Tablet not seeing server

I successfully set my phone up to remotely control EasyWorship 7. Then I tried my Samsung Tablet. It does not see the server (that page is blank). Phone still works to control it. Tried uninstalling and re-installing Bonjour - no help.



Is the tablet on the same WIFI as the phone?

Some devices need to be put in airplane mode then turn off airplane mode to get the bonjour functionality working again. I have to do that with my pixel 2.
Yes, the tablet is on the same Wifi SSID.

I tried airplane mode on and off and it didn't work. Then I rebooted it and tried it again and it did work (finally got the Server ID). After it went to sleep it wouldn't find the server ID again, but because I had previously selected the server ID, it did work (I could then pair to it and start controlling from remote). So, something is a bit flaky with the Android tablet finding the server name.

The bonjour functionality on some android devices is flaky. If the tablet has cell capability you might want to either disable that functionality or enable airplane mode and then turn wifi back on. Seems to have trouble if it loses wifi, it switches to trying to using cell service, but when it gets wifi back it can't switch back to the wifi connection.
I have the Android Remote app on my phone (Xiaomi Redmi Note 5) as well as on my Samsung Galaxy S Tab 2. Neither device will find the server. Tried toggling the phone's Airplane Mode on and off, but that did not work. Any ideas?

Make sure you're not connecting to a guest network. Also make sure your wifi and computer are on the same network.
Thanks, I am moving forward a bit. I had enabled Remote in the Options, but failed to turn it on at the top of the menu. That launched a download and install of Bonjour, which I thought was already installed. Anyway, now my phone can see the slides of a song, and I can scroll through them on the device, but I can't actually advance the slides. Maybe I'm still missing something.
OK, where is the palm plant emoji? Just re-read the instructions and had missed the step to click on the lock icon...now it works. Thank you.