Powerpoint outputs black via NDI but songs OK.

For over a year I have been using NDI output from Easyworship to vMIX. Everything was working fine then two weeks ago I suddenly got just a black screen in vMix when I tried to use a Powerpoint EZW. Yet songs and scriptures shown in EZW still output absolutely fine via NDI to vMIX.


I am running everything on one computer and our church does not have a spare. I know desktop capture is a workaround but it is far from ideal as the full screen PPT display cover up views of other software. 


Is there a definitive solution to this problem as I see many others have reported similar issues?


If it worked correctly for over a year and suddenly started having this issue 3 weeks ago the logical solution is to determine what changed in the week prior to the issue started. What software updates did you install? What hardware did you change. 99.9% a sudden problem like this is due to a change or update. And unless you decided to update to a newer version of EW 3 weeks ago (and the latest release of EW came out in November of 2020, 7 months ago so I seriously doubt you suddenly decided to update to that, the issue is with whatever change you made to the software or hardware of your computer. Revert back to the previous version of whatever you changed and you'll more than likely fix the issue.

Thanks for that response. That potentially eliminates EZW as causing the problem but I was hopng for some more specific help on what other software might have caused this problem especially if other users have experienced it. It is likely both McAffee, Microsoft and Vmix products have been updated and who knows what else goes on in the background. I do not know how to 'roll back' a system so hoping that someone else had experienced the problem and found the solution. 

McAffee is a joke and should never be allowed anywhere near a computer. It's essentially junk and causes too many problems. Windows 10 built in Defender is considerably better overall and unless you are a big company the average user would never need anything more.


The main updates that would cause issues would be Vmix or OBS (depends on which program one uses), NDI, MS Office/PPT, and graphics drivers.


VMix releases updates on a regular basis. They just released on a couple of days ago as well as one about 3 weeks ago. You might want to go to the Vmix forums (found on the Vmix website) for information on the best way to roll back to a previous version as well as help with your NDI problem.


https://www.howtogeek.com/235474/how-to-roll-back-builds-and-uninstall-updates-on-windows-10/



Roy I’d like to know if you ever found a solution. I am running two separate computers and I have never been able to get PowerPoints in EW to show up in the vMix NDI input unless I convert the presentations into png images or mp4 videos instead. If you haven’t tried that yet that’s a nice workaround, but I would really like to not have to do that. Meanwhile, if I find anything out I’ll post here again.

Yes, this was fixed by a. EasyWorship upgrade. I did not know so many update were available because the 'check for updates' function in EZW was not showing anything. When it looked through the info on various updates a fix to this problem was mentioned so I just updated to the latest version and it is fine now. We are running on one computer though. Hope this helps. Roy

Login to post a comment